Gates 5 all PDM Amps short

AM Radio discussion. Directional arrays are FUN!
Post Reply
sgibson
Posts: 9
Joined: Fri Oct 16, 2015 1:32 am
Location: Australia

Gates 5 all PDM Amps short

Post by sgibson » Wed Nov 09, 2016 12:20 am

Hi, I have a Gates 5 that has all the PDM Amp short lights showing as well as the PDM Kill when ever I try and start it up. I found 1 dead FET on 1 of the boards with a dead fuse but everything else I tested seems OK. I was thinking it was on the control side because all the lights are on but was hoping someone might have seen this before.

ncradioeng
Posts: 15
Joined: Wed Nov 18, 2015 3:58 pm

Re: Gates 5 all PDM Amps short

Post by ncradioeng » Wed Nov 09, 2016 9:32 am

It acts like the interlock is open or there is no PDM drive - does it come on in "local" mode?

ncradioeng
Posts: 15
Joined: Wed Nov 18, 2015 3:58 pm

Re: Gates 5 all PDM Amps short

Post by ncradioeng » Wed Nov 09, 2016 9:39 am

Also, check the auxiliary contacts on the contactors in the bottom panel - if they have dust in them and don't make, that will cause it not to come on.

Aetheradio
Posts: 10
Joined: Sat Aug 25, 2012 11:19 pm
Location: Omaha, NZL

Re: Gates 5 all PDM Amps short

Post by Aetheradio » Thu Feb 23, 2017 2:02 am

We've had a couple of instances of "short circuit sense alarm" on a particular board ( A6, 7, 8, 9)

after swapping boards around the fault moved with the board
both times it was one of the 100k resistors gone funny these are in the PDM fault detect cct I think - possibly R64 or R63

these feed to the sense IC there was never any faulty FETs found (replaced them in the first instance)

must stock up on more 100k resistors its probably a bad batch to have happened at different times to different boards

I'm glad the rig is now only a standby - it popped these alarms just after it was replaced - but we still need to keep it running - less pressure though.

Ralph

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest